PROBLEMAS CON EL FORO Y LA WEB

¿Tienes alguna duda sobre entrenamiento? ¿No consigues hacer crecer tus músculos? ¿Estás perdido sobre algún concepto de musculación ?. ¿Tu dieta no te sirve para adelgazar o ganar peso?. Quizás sólo quieres expresar una opinión, publicar tu rutina, o una experiencia en el gym... este es tu sitio. ¡¡LOS NOVATOS SON BIENVENIDOS!!

Moderadores: WilburWhateley, JazzyJames, juan weider, Maokoto, Sleerash

Responder
Haqim
Herrero Senior
Mensajes: 150
Registrado: Lun Oct 05, 2015 6:44 pm

PROBLEMAS CON EL FORO Y LA WEB

Mensaje por Haqim » Dom Sep 08, 2019 7:50 pm

Saludos y disculpad el tema off-topic.

Desde hace un tiempo y después de alguna actualización, la web y el foro fallan mucho a la hora de acceder mediante URL directa desde navegador o desde enlaces antiguos. Los problemas principales son básicamente 2:

1. Si no especificas explícitamente HTTPS:// en la dirección (URL), la web no carga.
2. Si no pones una "/" al final de la URL para acceder al blog, la web no carga. (Ej: https://masfuertequeelhierro.com/blog). El foro no tiene ese problema.

La solución:

1. Forzar una redirección automática de las URL's HTTP:// a HTTPS:// mediante un plugin de wordpress, o directamente tocando el .htaccess:

https://www.aemilius.net/ayuda/articulo ... mente.html

2. Revisar la configuración de Wordpress o del .htaccess para corregir el problema de la "/" final.

Simplemente espero ayudar para que este foro y el blog no decaigan, ya que muchas URL's antiguas (enlaces) tanto dentro como fuera de la web y el blog ya no funcionan, cosa que aparte de hacer perder visitas, Google penaliza mucho a la hora de indexar y mostrar la web entre sus resultados.

Un saludo.

Avatar de Usuario
Maokoto
Administrador del Sitio
Mensajes: 13328
Registrado: Vie Ago 14, 2009 7:11 am

Re: PROBLEMAS CON EL FORO Y LA WEB

Mensaje por Maokoto » Jue Sep 12, 2019 1:00 pm

Haqim escribió:
Dom Sep 08, 2019 7:50 pm
Saludos y disculpad el tema off-topic.

Desde hace un tiempo y después de alguna actualización, la web y el foro fallan mucho a la hora de acceder mediante URL directa desde navegador o desde enlaces antiguos. Los problemas principales son básicamente 2:

1. Si no especificas explícitamente HTTPS:// en la dirección (URL), la web no carga.
2. Si no pones una "/" al final de la URL para acceder al blog, la web no carga. (Ej: https://masfuertequeelhierro.com/blog). El foro no tiene ese problema.

La solución:

1. Forzar una redirección automática de las URL's HTTP:// a HTTPS:// mediante un plugin de wordpress, o directamente tocando el .htaccess:

https://www.aemilius.net/ayuda/articulo ... mente.html

2. Revisar la configuración de Wordpress o del .htaccess para corregir el problema de la "/" final.

Simplemente espero ayudar para que este foro y el blog no decaigan, ya que muchas URL's antiguas (enlaces) tanto dentro como fuera de la web y el blog ya no funcionan, cosa que aparte de hacer perder visitas, Google penaliza mucho a la hora de indexar y mostrar la web entre sus resultados.

Un saludo.
El cambio a https, y todas las molestias que ha conllevado y conlleva, son culpa de que me vi prácticamente forzado por Google a instalarlo debido a sus políticas. Después del cambio (obviamente y como me temía) fallan muchísimas cosas. Las soluciones que tú mencionas ya han sido aplicadas sin éxito alguno. El hosting no hace bien las redirecciones (es más, al principio todo funcionaba perfecto, hasta que actualizaron no se qué y dejó de funcionar). Es algo que me he mirado, pero no he encontrado solución fácil, y no me da tiempo de aplicar una complicada.

Ahora me está diciendo wordpress que el php que uso es obsoleto, pero si lo actualizo, dejarán de funcionar otra serie de cosas. En fin... que ahora mismo no tengo el tiempo ni el deseo de buscar y arreglar tantísimos fallos. Ni me merece la pena.

Sé perfectamente que el blog y el foro decaen, pero estoy ocupadísimo y bastante tengo con mantenerlo tal como está.

Un abrazo y gracias por tu intención de ayudar.

Responder